La Evolución Natural de Internet

Para poder explicar qué es IPv6, debemos hablar y compararlo con el protocolo actual IPv4. Actualmente nos enfrentamos al grave problema de que el direccionamiento IPv4 público se ha agotado, deteniendo el crecimiento de Internet debido a que no se pueden incorporar nuevas máquinas a esta gran Red.

IPv4 en sus inicios fue diseñado para conectar unas pocas redes, universidades y redes militares en EEUU, sin pensar en un despliegue comercial, quedando a los pocos años de su implementación corto en su espacio de numeración.

IPv4 - El Pasado

  • 32 bits de direccionamiento
  • ~4.3 mil millones de direcciones
  • Agotado desde 2011
  • Requiere NAT y traducción
  • Limitaciones de seguridad
  • Configuración compleja

IPv6 - El Futuro

  • 128 bits de direccionamiento
  • 340 undecillones de direcciones
  • Disponible y escalable
  • Conectividad end-to-end
  • Seguridad nativa IPSec
  • Auto-configuración

Historia del Protocolo IPv6

1995
Nacimiento de IPv6 según RFC1883 - Primera especificación oficial
1998
RFC2460 - Especificación que nos acompañó durante largo tiempo
2011
Agotamiento oficial de direcciones IPv4 públicas
2017
RFC8200 - Estándar actual de IPv6 (julio 2017)
2017
Resolución MinTIC 2710 - Colombia impulsa la adopción de IPv6
Hoy
IPv6 es la realidad - Ya no es el futuro, es el presente

IPv6: La Internet del Ahora

Cuando se creó Internet, no se pensó que su crecimiento fuera a ser tan grande y a medida que se tornó más comercial, hizo que la cantidad de direcciones IPv4 fueran insuficientes. En el año 2011 las direcciones de IPv4 se agotaron, y pensar que podemos escalar el protocolo y seguir utilizándolo es totalmente utópico.

IPv6 puede considerarse como la evolución natural de IPv4, es la red del ahora, ya no podemos decir que es la red del futuro. ¿Nuevo protocolo de Internet? Realmente el protocolo IPv6 nace desde 1995, según RFC1883, y ahora es estándar (RFC8200) en julio 2017, pasando por el RFC2460 de diciembre de 1998, que nos acompañó durante un largo tiempo.

¿Por Qué IPv6 es Duradero?

Debido al tamaño de IPv6 (128 bits contra 32 de IPv4), se estima que no se reemplazará por los próximos 300 a 400 años para los optimistas, 50 para los pesimistas. Lo más probable es que no tengamos que realizar otra transición tecnológica de tal magnitud en el transcurso de nuestras vidas.

No queriendo decir con esto que no pueda llegar a existir otras maneras para comunicarnos en los próximos años, ¿por qué no? Por lo pronto esto es lo que tenemos: IPv6, la Internet del ahora y del futuro.

Ventajas Técnicas de IPv6

Espacio de Direcciones

340.282.366.920.938.463.463.374.607.431.768.211.456 direcciones únicas

Seguridad Nativa

IPSec integrado para comunicaciones seguras por defecto

Auto-configuración

Los dispositivos se configuran automáticamente sin DHCP

Eliminación de NAT

Conectividad directa end-to-end sin traducción de direcciones